Версия компоненты ‘comcntr’ (8.3.8.2054) отличается от версии корневого модуля ‘core83’ (8.3.10.2505)

image_pdfimage_print

Доброго времени суток!

Я думал, что знаю о COM+ настройке в 1С все, но оказалось интересней с переходами платформы 8.3.8 на 8.3.10
http://sikuda.ru/archives/352

При попытке подключения из SQL базы с платформой 8.3.10 по COM к старой серверной платформе 8.3.8 выдается ошибка:

«Ошибка при вызове метода контекста (Connect): Произошла исключительная ситуация (V83.COMConnector.1): Несоответствие версий клиента и сервера 1С:Предприятия
Различаются версии клиента и сервера (8.3.10.2505 — 8.3.8.2054), клиентское приложение: COM-соединение»

Раньше было достаточно зарегистрировать нужную dll из старой версии и COM соединение к новой платформе перестает работать, а к старой работает. Но теперь

К старой версии 8.3.8

Ошибка при вызове метода контекста (Connect): Произошла исключительная ситуация (V83.COMConnector.1): Версия компоненты ‘comcntr’ (8.3.8.2054) отличается от версии корневого модуля ‘core83’ (8.3.10.2505)

К новой версии 8.3.10 такая же ошибка.

 

Шаманства типа с  регистрацией не всегда  помогают: http://novichok1c.ru/ustranenie-oshibki-pri-podklyuchenii-k-baze-dannyh-1s-cherez-com-soedinenie

Так что проблема остается. Рекомендация — устанавливать единую платформу 8.3 на все конфигурации.

 

 

 

 

 

Добавить комментарий